CPFlight Panels not working

Seek help from others on hardware issues
edmoore
Posts: 14
Joined: Thu Apr 07, 2022 11:15 am

Re: CPFlight Panels not working

Post by edmoore »

Thanks! Will check ASAP.

jeehell
Site Admin
Posts: 368
Joined: Mon Jun 15, 2020 9:36 pm
Location: France
Contact:

Re: CPFlight Panels not working

Post by jeehell »

If you donwloaded it just now, ACPs might be working as well
Regards,
Jean Luc

edmoore
Posts: 14
Joined: Thu Apr 07, 2022 11:15 am

Re: CPFlight Panels not working

Post by edmoore »

Hey Jean Luc, update on your latest DLL:

- Panel backlight still only on FCU, none of add-on panels are lit
- FCU displays now working correctly
- RMP control panels - all physical buttons and encoders work and affect software panels. However frequency displays don't change from 118.000 and green indicator LEDs stuck on defaults (VHF1 and VHF2 respectively)

Here's the log: https://pastebin.com/Sx13YL7E

edmoore
Posts: 14
Joined: Thu Apr 07, 2022 11:15 am

Re: CPFlight Panels not working

Post by edmoore »

Just saw your note about the ACP:

- No backlighting or indicators
- Call buttons don't work
- Pushing in and out the volume pots works
- Turning volume pots doesn't work
- int/rad switch works
- On voice switch works
- PA switch doesn't work

jeehell
Site Admin
Posts: 368
Joined: Mon Jun 15, 2020 9:36 pm
Location: France
Contact:

Re: CPFlight Panels not working

Post by jeehell »

It seems from the logs that the new modules don't signal their presence as expected, so my software does not send anything to save bandwidth. I will try another approach, i should have something tonight.
Regards,
Jean Luc

jeehell
Site Admin
Posts: 368
Joined: Mon Jun 15, 2020 9:36 pm
Location: France
Contact:

Re: CPFlight Panels not working

Post by jeehell »

Ok i just updated the file the last url should still be valid. Let me know if it makes a difference.
Regards,
Jean Luc

edmoore
Posts: 14
Joined: Thu Apr 07, 2022 11:15 am

Re: CPFlight Panels not working

Post by edmoore »

update - backlights still not working on anything except FCU
RMP frequency display WORKS
RMP encoders WORK
FCU all works but initially shows random alt and VS - corrects itself when adjusted
No indicator lights yet working on RMP/ACP

Post Reply